All services are still operational and no new issues have been reported since Monday.
Posted Oct 23, 2025 - 09:50 PDT
Monitoring
Canvas is back online and available. At this time, access to all major services should be restored. We will continue to monitor status updates from Amazon.
Posted Oct 20, 2025 - 16:07 PDT
Update
Wēpa Printing (lab printing) is back online and available.
Canvas is still unavailable at this time -- Instructure and Amazon are continuing to work to resolve the issue (more information at https://status.instructure.com).
Posted Oct 20, 2025 - 13:41 PDT
Update
Amazon and Canvas are continuing to investigate the issue. You can check the current status of Canvas by visiting https://status.instructure.com/.
Posted Oct 20, 2025 - 11:48 PDT
Identified
Canvas and Wēpa Printing are currently unavailable due to an Amazon Web Services (AWS) outage. More information will be posted as it becomes available, and current service availability can be found on the OIT Status Page. Once Canvas is available again, you may need to clear your browsing cache to access the system.
Posted Oct 20, 2025 - 11:43 PDT
This incident affected: Desktop and Mobile Computing (Lab Printing), Teaching and Learning (Canvas), and Administrative and Business (Confluence View Content, Confluence Create and Edit, Jira Service Desk Web, Jira Service Desk Portal, Jira Software Create and edit, Jira Software Viewing content).