An issue with our shared storage appears to have been the underlying cause of this event. Since it's been resolved, the stability of the server environment has significantly improved. We're still continuing to monitor and tune the server environment to improve performance and reduce the risk of recurrence. We'll also be conducting an internal review of the incident to evaluate and continue to improve the stability of our services and incident response.
Posted Jan 26, 2026 - 10:10 PST
Update
The server environment has remained in a stable state for over 24 hours with no outages or new concerns emerging. We will continue to closely monitor for any signs of recurrence and we encourage you to please report any issues you experience with these services.
Posted Jan 15, 2026 - 16:53 PST
Monitoring
The server environment has remained in a stable state overnight and we expect that all services are back online. We will continue to closely monitor for any signs of recurrence and we encourage you to please report any issues you experience with these services.
Posted Jan 15, 2026 - 09:00 PST
Update
We have implemented a fix provided by our hardware vendor and are seeing significant improvement in the server environment. The majority of impacted services are back online, and we will continue work on resolving a small number of remaining issues and monitor closely for any signs of recurrence.
Posted Jan 14, 2026 - 18:07 PST
Update
Access to the I: drive and H: drive has been restored. We are continuing to work to bring other impacted services online.
Posted Jan 14, 2026 - 14:00 PST
Update
In an attempt to resolve the larger issue, we will be temporarily shutting down several systems starting at 12:40pm today, including the I: drive and H: drive. We expect these systems to be back online by 2:00pm.
Posted Jan 14, 2026 - 12:26 PST
Identified
We're continuing to work with the vendor and believe that a fix has been identified. Given the size of our server environment, it will likely take until the early afternoon to fully implement. In the meantime, we are prioritizing bringing impacted student and other critical services (such as the Library website, departmental printing, and specialized student printing) back online as soon as possible.
Posted Jan 14, 2026 - 10:39 PST
Investigating
We are currently experiencing issues with our server environment causing instability and downtime for several campus services. Affected services include employee printing, OIT-provided server hosting for departments, and some other applications related to administrative operations.
Core student-facing services such as Canvas, Banner, myPSU, and the PSU website are unaffected by this, but a few student-facing services, such as specialized student printing (which does not include Wepa kiosks) and the library website may be unavailable as well. Customers may experience additional instability or downtime while we work with our vendors to resolve the underlying issue.
Posted Jan 14, 2026 - 09:34 PST
This incident affected: Web Services (OIT Web Hosting) and Desktop and Mobile Computing (Office Printing).