Banner and myPSU outage

Incident Report for Portland State University

Resolved

Banner, myPSU, and related services are back online and available. We are actively monitoring to ensure ongoing stability.
Posted Jun 17, 2026 - 16:58 PDT

Update

Banner, myPSU, and related services remain unavailable. We expect service to be restored by 4:30 pm. Thank you for your continued patience.
Posted Jun 17, 2026 - 15:51 PDT

Update

Banner, myPSU, and related services remain unavailable. We expect service to be restored by 3:30 pm.
Posted Jun 17, 2026 - 14:15 PDT

Identified

Banner, myPSU, and related services remain unavailable. We have identified a resolution and are implementing it. We do not expect service to be restored before 2:30 pm.
Posted Jun 17, 2026 - 12:47 PDT

Investigating

Banner, myPSU, and related services are unavailable. We are investigating to learn more and restore service as soon as possible.
Posted Jun 17, 2026 - 11:56 PDT
This incident affected: Administrative and Business (Banner, Banner Data Integrations, myPSU).