Intermittent Duo outage
Incident Report for Portland State University
Resolved
This incident has been resolved.
Posted Aug 20, 2018 - 09:00 PDT
Identified
Duo authentications are failing intermittently, see https://status.duo.com/
Posted Aug 20, 2018 - 08:53 PDT