Qualtrics Unavailable
Incident Report for Portland State University
Resolved
This incident has been resolved.
Posted May 21, 2018 - 11:06 PDT
Update
We are continuing to investigate this issue.
Posted May 21, 2018 - 11:03 PDT
Investigating
Qualtrics online survey software is experiencing a data center outage.
This service is currently unavailable.
Posted May 21, 2018 - 11:02 PDT